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What Is Spud City To-Do?
Is it a new type of french fry? Perhaps a long-forgotten ragtime tune?

No, it's a powerful to-do list manager that's very easy to understand and use. Other to-do programs 
tend to be so complex that they take months to learn, or are so basic that they lack important 
features. Spud City To-Do puts it all together in a design that everyone can use, beginners and 
power users alike.

Take a minute to try it; you'll use it for years.



Three-Minute Tutorial
Print Out This Topic!
Before you start, we recommend that you print out this help topic. Having a hard copy of the three-
minute tutorial will make it easy to follow along as we take a brief, yet luxurious cruise through the 
serene waters of Spud City To-Do.

To print it out, turn on your printer and press the Print Topic button.

Add A Couple Of New Tasks
We'll start our voyage by adding a few tasks to the current task list (as opposed to the archive task 
list, which we'll talk about later).

1 Press the Add button. You now see the Add/Edit form.
2 Type your task's description in the wide yellow box at the top of the page.
3 Use your mouse or press the tab key to move to the calendar. Use your arrow keys or mouse to 

select a due date for the task you just typed in.
4 Set its level of importance (if any) in the Priority section.
5 Write up a memo to go along with it, if you wish.
6 Press the Done button. Wow! You just added a task.

Repeat these steps four or five times (or more, if you're compulsive). Use different due dates; some 
earlier than today, some later.

When you've got a jolly little crew of tasks assembled on the current task screen, lean back and 
admire your work.

Notice that the colors of the tasks change depending on if they are upcoming tasks, if they are due 
today, or if they are overdue.

Edit Tasks
You can edit your tasks at any time. Click on one, then press the Edit button (or double click the 
task). The edit screen will appear. Here you can change any of the task's properties. Press the Done 
button when you're done.

If you just need to change your task's due date, and don't want to call up the edit screen, just press 
your left or right arrow keys, or your - or + keys the appropriate number of times. For instance, if you 
want to change an item's due date from the 20th to the 23rd, select the item in the task list, then 
press the + key (or right arrow key) three times, then press the Enter key.

Set Your Preferences
Here's where the real fun starts. From the Options menu at the top of the screen, choose Sort By.

Try switching to the different sort orders, and watch how they affect the way your data is displayed on
the screen.



Alarm
You need to set an alarm that matches your mood. From under the Options menu, select Alarm 
Sound.

Switch between the different alarm settings. If your computer is set up to play sounds for different 
Windows events, you SHOULD hear something. Stick with the one that sounds the best to you.

Archive A Task
This is how you'll tell Spud City To-Do what to do with your tasks after you've accomplished them. 
For instance, if one of your tasks says 'Wash the car', and you get the car washed, you'll want to take
that task off the list. You can either erase it forever, or archive it.

Archiving saves it to a dusty old file where aging tasks sit around and talk about the good old days. 
You can go visit these archived tasks anytime you want.

Let's send one of your tasks off to Archive-land.

1 Click on a task you want to pretend you're done with.
2 Press the Done button. You see a dialog box that asks what you want to do with the task.
3 Press the YES button. Poof! It's gone.

View Archive
Where do you suppose it went? Press the Archives button. Notice how the tasks here show the date 
they are completed. Also, note that they are sorted according to your currently selected sort order.

Now go back to the current task list by pressing the Current button.

Default Action For 'Done' Tasks
This setting lets you tell Spud City To-Do what to do automatically with your tasks when you press 
the Done button.

· If you know that you'll always want to archive your tasks, under the Options menu, select Default 
Action For 'Done' Tasks, then choose Archive All 'Done' Tasks.

· If you don't ever, ever want to see your tasks again, select Erase All 'Done' Tasks.
· If you want to choose whether to archive or erase tasks each time you're done with one of them, 

select Always Prompt For Decision.

Print Tasks
This offers a lot of nifty features. You can view or print out your tasks in many, many different ways.

1 To access it, press the Print button. You now see the print screen.
2 If you have a printer hooked up to your computer, choose the destination, Printer, from your 

choices at the bottom of the screen, then press the Create Printout button.
3 If you don't have a printer, simply press the Create Printout button; your report will be sent to 

your computer screen.
You should see all of your current tasks (and their memos). As you can tell from the other print 



options, you have complete control over which tasks will appear in your printouts. Press the Cancel 
button to return to the current task list.

Your tour is complete. You now have a good working knowledge of Spud City To-Do. Enjoy the 
program!



Working With Tasks
Add A Task
Edit A Task
What To Do When You're Done With A Task
How To 'Unarchive' Tasks



Add A Task
To add a new task to your list, press the Add button (if the button bar is visible), or select Add Task 
from the Task menu. You see a form which lets you fill in all the details of your task.

Also see:
Add/Edit Task Screen



Add-Edit Task Screen
The Add/Edit screen is displayed whenever you select Add or Edit. Here are its components:

Task
The wide yellow box at the top holds your task description. You can type in as many as 45 
characters. If you want to write more, we suggest you start up here, then use the Memo area at the 
bottom of the screen to finish your task description.

Priority
Select one of the four priorities. This will affect the order that your tasks are displayed in the task list. 
The default priority is None.

User Code
This is an optional entry to help you differentiate your tasks based on a coding scheme you make up 
yourself. For example, if you want to be able to keep track of all your tasks related to a    client, 
Smith, you might want to type in an S in the user code box each time you add a new Smith task. 
You'll see that you can isolate all the Smith 'S' tasks for display and printing purposes. The valid
entries here are the letters A to Z (they will be made upper case automatically), and the numbers 0 to
9. This gives you 36 different codes that you can assign.

Calendar
You can switch the due date using your mouse or arrow keys.

Alarm Time
Type a time in this box if you want to be reminded when a task should be done. If Spud City To-Do is 
running when the date and time comes due, a message box will pop up to remind you of the task, 
and an alarm will sound.

Repeat Task
If you have a task that you want to accomplish several times over a set period of time (for example, if
you want to water your plants every three days), use this feature to set it up. Press the Repeat Task 
button. Then just enter the number of times you want to repeat the task, and the interval of days 
between each task.

Memo
This is where you can write lengthy notes about a particular task. Some users like to write notes here
about the results of their tasks (often meetings and telephone conversations) so they will have a 
permanent record of who said what.



Edit A Task
To edit an existing task, you can press the Edit button (if the button bar is visible), or select Edit Task 
from the Task menu. You can also double-click on the task with your left mouse button. You see a 
form which lets you edit all the details of your task.

Also see:
Add/Edit Task Screen



Done With A Task
When you have completed one of your tasks (or just want to erase it) press the Done button or select
Done With A Task from under the Tasks menu. Depending on your Options setting under Default 
Action For Done Tasks, your
task either will be erased, archived, or you will be asked which of those choices you want.

Also see:
Default Action For Done Tasks



Default Action For 'Done' Tasks
This setting will determine what Spud City To-Do does with your tasks after you've accomplished 
them. You can either choose to archive all your done tasks, erase all your done tasks, or select from 
those choices each time a task is done.



Unarchive Task
The menu choice Unarchive Task is only available from under the Tasks menu when you are viewing 
archives. When you click the Unarchive Task item, whichever task is highlighted in the archive list will
be returned to the current task list.



Options
Sort By
You can group your tasks in different ways by changing the way they are sorted on the screen. 
Select Sort By from under the Options menu, then choose one of the four options:

· Date, then Priority, then User Code
· Date, then User Code, then Priority
· Priority, then Date
· User Code, then Date

Default Action For 'Done' Tasks
This setting will determine what Spud City To-Do does with your tasks after you've accomplished 
them. You can either choose to archive all your done tasks, erase all your done tasks, or select from 
those choices each time a task is done.

Default Due Date
Every time you call up the Add Task screen, the calendar shows a default date. That date is set 
according to what you have selected under Default Due Date, which is under the Options menu. You 
either can select Today, Tomorrow, or Day After Tomorrow.

Show Button Bar
You can hide or show the button bar by toggling on and off the menu choice Show Button Bar from 
under the Options menu. You know it's on if you see the check mark next to it. The button bar is darn 
handy to use, but it takes up space. Try it both ways. Suit    yourself.

Colors
To change the colors of the current list, select Colors from the Options menu. You'll see a list of 
thoughtful color combinations on the left hand side of the screen, and a sample of a list box on the 
right. Try the different color options, and select the one that looks best to you.

Icon Caption
If you have trouble getting your screen saver to 'sleep' try switching the Icon Caption from under the 
Options menu from Show Date And Time to Show Date Only.

Alarm Sound
Alarm sounds are an important part of Spud City To-Do. To select one that works best for you (and 
your computer), try the different ones available under Alarm Sound in the Options menu. Each time 
you select one, you SHOULD hear it. If you don't hear it, then select another one that you DO hear.

Limit View By Date
If a long, long to-do list depresses you, and you only want to see the tasks that are due within 7, 15, 
30, 60, 90, 180 or 365 days, you've come to the right option. Just click on the appropriate time range,
and all of the tasks that fall outside of that range will be 'hidden' for the time being. The caption at the
top of the task column reminds you that this is just a partial list.

Of course, as the days wear on, and your tasks come into the selected date range, they will appear 
once more. If you want to see all your tasks, irregardless of their due dates, select Show All Tasks.





Printing
This is a great feature. Even if you don't want a hard copy printout of your tasks, you can use the 
Print feature to search for text strings in your task descriptions and memos. Here's how everything 
works:

Task Due Status
Check off the types of tasks that you want to include in your printout. Your choices are Overdue 
Tasks, Today's Tasks, Upcoming Tasks, and Archived Tasks.

Dates
Your choices here are All Dates, Today Only, and Date Range.

· All Dates will consider all of your tasks for the printout.
· Today Only will only consider those tasks which are due today (or, for archived tasks, were 

completed today).
· Date Range will narrow the search down to a specified date range. Type in your beginning date 

and ending date for the search.

NOTE: If you're dealing with current tasks, the date searched will be the date due. However, if 
you're dealing with archived tasks, the date searched will be the date completed.

Priority
If you want to print out only tasks that have a certain priority, then make your wishes know here.

User Codes
If you want to narrow down your printout to tasks that contain only certain user codes, type them in 
here. You can squish them all together like this: AHZ Or you can separate them with spaces and/or 
commas, like this: A, H, Z.

Text Filter
If you are looking for a particular piece in either your task description or in your memo, then use Text 
Filter to help find it. Just type in the text you are looking for. Spud City To-Do will do a non-case 
sensitive search. That means if you type in here that you're looking for the word, bicycle, you'll get 
back any task or memo that includes bicycle, Bicycle, BICYCLE or BiCyClE. Pretty
weird, huh?

Header
A header is the title that appears at the very top of your printout. You can impress everybody by using
this feature to create your own custom header. I can almost hear the oohs and aahs now.

Note: This feature is only available to registered users. Non-registered users are stuck with the 
naggy header. Sorry about that, but we've got to pay for our kids' happy meals somehow.

Destination
Where do you want your report to go? If you want to see it on your computer screen, select the 
Computer Screen option. If you want it to print on paper, select Printer. If you'd rather work with a text



file, select File. It will be saved in the same subdirectory as your To-Do program, under the name 
TODO.TXT. If you already have a file named TODO.TXT in that subdirectory when you create a new 
one, the old one will be erased. It's a cruel world sometimes.

Create Printout
This is the button you push to actually have Spud City To-Do search your tasks and compile the 
printout. Keep in mind that for a task to appear on your printout, it must match ALL of the criteria that 
you set on this screen.



Keyboard Shortcuts & Other Goodies
Keyboard Wizardry
If your program's focus is on the current task list, the following keys will perform these actions:

· E = Edit
· A and Insert key = Add
· D and Delete key = Done
· + and right arrow key = Move this task's due date ahead by one day each time you press the 

key.
· - and left arrow key = Move this task's due date back by one day each time you press the key
Note that if the focus is on the button bar, these keys won't do anything. To set the focus on the 
current task list, click on it once with your mouse. Now you're in business.

Double-Click To Edit
Double click on any of the tasks on your list, and you'll take that task into the Edit screen. This works 
with tasks on both the current and archive lists.

The Long And The Short Of It
Grab the bottom of the Spud City To-Do window and drag it up to make it shorter. The list box will 
shrink proportionally. Try the opposite. Grab the bottom of the window and make it longer.

Aren't you glad you read this help topic?



Running On A Network
It's possible to store Spud City To-Do's data files on a network. The only reason you'd want to do this 
is if the network drive gets backed up more frequently than the local drive.

NOTE: Don't attempt this network drive thing unless all of these instructions make perfect sense to 
you and you know what the hell you are doing.

1 First, install Spud City To-Do normally on your local computer's hard drive.
2 Make an icon for it in a window group.
3 Run it at least once to make ensure that the six M1.xxx and M2.xxx files (three of each) get 

created.
4 Exit Spud City To-Do.
5 Now, create a subdirectory on your network drive to hold those files.
6 Copy the six M1 and M2 files to this new network subdirectory.
7 Erase the six M1 and M2 files from your local hard drive.
8 Click ONCE on the icon that starts Spud City To-Do (but don't start it!).
9 Under Program Manager, select the File menu, then choose Properties.
10 Look at the box designated Command Line. After the path that appears in the Command Line 

entry, add a space and then the path name to your network subdirectory.

For example if it now reads C:\TODO\TODO.EXE and you moved the M1 and M2 files to F:\
HARRY\TODO\ then change the command line to read: C:\TODO\TODO.EXE F:\HARRY\TODO\

The next time you start Spud City To-Do from your icon, it will use the data files on your network.



Registration Information
Is This A Free Program?
No. Spud City To-Do is distributed using the shareware method. That means you're free to try it for a 
month to see if you like it. If you decide to keep it beyond the trial period, send in your registration fee
to us (Spud City Software), and we'll mail you back your very own registration code. This will make 
you an official registered user. Join the club. Learn the secret handshake. Do the dance.

What Is Its Price?
Spud City To-Do won't bankrupt your piggy bank. It only costs $14.50 to register. If you want to 
register your copy AND receive the latest version on disk, send us a total of $19.50. That's a small 
price to pay for organizing your life and making you a better person (who knows, it might make you 
the next Nobel Peace Prize winner).

Registration Benefits
No More Nag Screen
Spud City To-Do registered users are given a registration code that rids them of the 'nag screen' that 
appears when the program starts. You say you haven't seen a nag screen yet? You will, sooner or 
later.

Ability To Change Report Header
Only registered users can create custom headers in printouts.

Access To Upgrades And Updates
We also contact registered users when major upgrades are released, and offer it to them at a 
substantial discount. Also, if a significant bug is discovered, only registered users will be contacted 
with a fix for it (let's hope it never happens, though).

Encourage New Features, Innovation
Your registration allow us to devote more time improving and upgrading Spud City To-Do.

Payment Options
Okay, I'm Hooked. How Do I Pay?
· If you want to pay by check, VISA, or MasterCard and you have a printer:

From under the Help menu, select Registration, then Reg. Form. Fill in your name and other 
information. Print out the registration form and mail it in.

· If you want to pay by check, VISA , or MasterCard and you DON'T have a printer:

Write us a note, saying that you want to register a copy of Spud City To-Do. Tell us your name 
and address, and what version you're using now. If you want to pay by credit card, write down 
your card number, expiration date, and sign your name somewhere. If you're paying by check, 



include that. Send the whole ball of wax off to: Spud City Software Co., P.O. Box 16062, Boise, 
ID 83715.

· If you have CompuServe account, here's a payment option:

While logged in to CompuServe, type GO SWREG and follow the prompts.

Spud City To-Do's program ID number for registration only is 3769. For registration AND the 
latest copy on disk, the program ID number is 3770.

The $14.50 or $19.50 gets added to your next month's CompuServe bill.

Within a day or two of registering via SWREG,    Spud City Software Co. will E-Mail you a 
confirmation.

· If you have e-mail access to CompuServe or the Internet, and want to pay by credit card, here's 
yet another payment option:

Leave us an e-mail message at 76660,3524 for CompuServe, or spudcity@micron.net for the 
Internet. Explain that you want to register your copy of Spud City To-Do. We'll send back an e-
mail to you, requesting the appropriate credit card information and verifying the amount of the 
transaction.

I Live Outside The U.S., Should I Pay A Little More?
Not unless you're filthy rich and don't care about money. In that case, pay 100 times the regular 
amount. Otherwise, pay the standard $14.50 or $19.50.

Multiple Registrations
What's The Price To Register Several Copies?
It depends on how many you want. Write to us with the approximate quantity you have in mind.



Spud City Software Co.
Based in Boise, Idaho, Spud City Software Co. is a microscopic corporation that specializes in 
shareware programs.

Spud City Software Co.
P.O. Box 16062
Boise, ID 83715

CompuServe ID: 76660,3524
Internet: spudcity@micron.net

Thank you for your interest in this program!



Warranty and Disclaimer
Software
Spud City Software Co. warrants that the software contained herein will perform in substantial 
compliance with the documentation accompanying the software. If you report, in writing, a significant 
defect to us and we are unable to correct it within 30 days of the date you report the defect, you may 
return the software and accompanying materials, and we will refund the purchase price.

Diskettes and Documentation
Spud City Software Co. warrants all diskettes and documentation to be free of defects in materials 
for 30 days from the date of purchase. In the event of notification within the warranty period of 
defects in any materials, Spud City Software Co. will replace the defective diskette or documentation.

Remedies
The remedy for breach of warranty shall be limited to replacement and shall not encompass any 
other damages, including but not limited to loss of profit, special, incidental, consequential, or similar 
damages, losses, or claims.

Disclaimer
Spud City Software Co. specifically disclaims all other warranties, expressed or implied. This 
includes, but is not limited to, implied warranties of merchantability and fitness for a particular 
purpose. In no event shall Spud City Software Co. or its owners be liable for any loss of profit or any 
other commercial damage, including but not limited to special, incidental, consequential or other 
damages.

Governing Law
This Warranty and Disclaimer statement shall be construed, interpreted, and governed by the laws of
the State of Idaho.

Required VB/ISAM Statement
This software was created using VB/ISAM, Copyright Software Source 1991-1994; all rights 
reserved. VB/ISAM software may not be used, copied, modified, transferred, or distributed except as 
expressly provided in its software license. Only licensees of VB/ISAM may create software that uses 
any part of VB/ISAM. Software Source, Freemont, California, USA; telephone (510) 623-7854.






